Quick Fix Letsencrypt dns error on home assistant

home assistant

175 Words

2026-09-26 12:32 +0200


If you encounter the following error on the letsencrypt add-on log :

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='acme-v02.api.letsencrypt.org', port=443): Max retries exceeded with url: /directory (Caused by NameResolutionError("HTTPSConne>
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

You might have a problem on your dns config.

First connect to a console on home assistant. In order to do that i’ve installed the following add-on: “Terminal & SSH” And then I’ve connected in ssh.

Then analyse the dns config:

ha dns info

If you have got no dns servers except local ones

fallback: true
host: 172.30.32.3
llmnr: true
locals:
- dns://192.168.0.254
- dns://9.9.9.10
- dns://9.9.9.9
mdns: true
servers:
- dns://9.9.9.9
update_available: false
version: 2026.09.0
version_latest: 2026.09.0

To add a dns server:

ha dns server <your dns server, you can add the quad9 if needed 9.9.9.9>

Then restart let’s encrypt and analyse the logs:

ha apps start core_letsencrypt
ha apps info core_letsencrypt
ha apps logs core_letsencrypt

If there are no errors you can restart home assistant:

ha core restart